Follow

Browser Requirements For The Document Reader

The Document Reader & Annotations tool uses HTML5 to render PDF documents. Your browser must therefore support this language. If your browser does not support it, the Document Reader option will not appear.

*Note that different versions can support different levels of HTML5.

Below is a list of browsers and minimum versions required for optimal use of the tool:

  • Google Chrome 10+
  • Mozilla Firefox 8+
  • Safari 5+
  • Internet Explorer 11+

When possible, we recommend updating your favorite browser to the latest stable version available.

(Currently not supported if you are using IE 10 or below. Click here for more information on Internet Explorer supported browsers.)

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk